The reporting delays we were experiencing with ACH.COM (https://secure.ach.com/) appears to be resolved. We apologize for the inconvenience and thank you for your patience and continued support. Please rest assured that system reliability is a top priority at Priority Payment Systems, and we are making continuous improvements to make our systems better.
Posted Aug 04, 2024 - 19:16 EDT
Update
We are currently investigating why many reports in ACH.COM (https://secure.ach.com/) are not showing updated data. We are actively researching and will provide more information shortly.
Posted Aug 04, 2024 - 17:11 EDT
Update
We are investigating reports that ACH.COM (https://secure.ach.com/) is unavailable. We are actively researching and will provide more information shortly.
Posted Aug 04, 2024 - 15:19 EDT
Update
We are currently investigating why many reports in ACH.COM (https://secure.ach.com/) are not showing updated data. We are actively researching and will provide more information shortly.
Posted Aug 04, 2024 - 11:49 EDT
Update
Our team has identified a problem affecting the reporting feature on (https://secure.ach.com/). When users click the reporting button, they receive an error message, and reports are not being generated as expected. This issue is impacting all users
Posted Aug 04, 2024 - 09:08 EDT
Identified
Our team has identified a problem affecting the reporting feature on (https://secure.ach.com/). When users click the reporting button, they receive an error message, and reports are not being generated as expected. This issue is impacting all users